NodejsAgent Support Matrix
warning
-
Only the minimum and maximum minor versions of each major version have been tested and verified.
-
Starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0), monitoring for ECMAScript Module (ESM) applications is supported.
Recommendation: If the monitored application heavily uses Promises, async/await, or high-frequency asynchronous tasks, it is recommended to upgrade the agent to NodejsAgent 8.0.0 (SmartAgent 10.1.0) and Node.js to version 14.18 or later for better asynchronous tracing performance.
Operating Systems
| System Type | Supported Versions |
|---|---|
| CentOS/Red Hat Linux | 6.x x86_64 |
| CentOS/Red Hat Linux | 7.x x86_64 |
| CentOS/Red Hat Linux | 8.x x86_64 |
| Ubuntu | 16.04 x86_64 |
Versions
| Type | Supported Versions |
|---|---|
| Node.js | v6.14.2+ |
| Node.js | v8.x.x |
| Node.js | v10 |
| Node.js | v12 |
| Node.js | v14 |
| Node.js | v16 |
| Node.js | v24.14.1 Supported starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
Node.js Runtime
| Item | Notes |
|---|---|
| Runtime metrics | Collects Node.js runtime metrics including total heap memory, used heap memory, external memory, ArrayBuffer memory, and event loop utilization Supported starting from NodejsAgent 8.1.0 (SmartAgent 10.4.0) |
Databases
| Type | Supported Versions |
|---|---|
| MySQL | mysql 2.13.0 ~ 2.18.1 |
| PostgreSQL | pg 6.2.4 ~ 8.7.1 |
| SQLite | 5.0.2 ~ 5.1.6 |
NoSQL
| Type | Supported Versions |
|---|---|
| Redis | ioredis 2.5.0 ~ 4.28.3 redis 2.8.0+ hiredis 0.5.0+ Supported ioredis 5.8.2 starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
| MongoDB | mongodb 2.2.31 ~ 4.1.3 mongoose 5.0.10 ~ 5.2.0 Supported mongoose 5.13.22, 8.23.0 starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
| Cassandra | cassandra-driver 4.4.0 ~ 4.6.3 node-cassandra-cql 0.4.4 ~ 0.5.0 |
| Elasticsearch | 16.7.1 Supported starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
Remote Calls
| Type | Supported Versions |
|---|---|
| HTTP | Built-in Node.js |
| HTTP/2 | Built-in Node.js |
| gRPC | 1.1.0 ~ 1.10.1 |
| RabbitMQ | rabbit.js 0.4.4+ amqplib 0.5.2 ~ 0.8.0 Supported amqplib 0.10.0, 0.10.9 starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
Frameworks
| Framework | Supported Versions |
|---|---|
| Express | v3.4.8 ~ 4.18.0 Supported Express 4.19.2 starting from NodejsAgent 8.0.0 (SmartAgent 10.1.0) |
| Koa | v2.2.0 ~ 2.13.0 |
| LoopBack | v2.x.x ~ v3.x.x |
| Hapi | v17.0.0 ~ 17.4.0 |
| Nuxt.js | 2.15.3 ~ 3.9.1 Supported Nuxt.js 3.17.4 (ofetch 1.5.1) starting from NodejsAgent 8.1.0 (SmartAgent 10.4.0) |
| Next.js | 10.1.0 ~ 10.2.3 |
| Egg.js | 2.15.1 ~ 2.37.0 |
Node.js Libraries
| Type | Supported Versions |
|---|---|
| Promise | 8.0.1 ~ 8.1.0 |
| Bluebird | 3.5.1 ~ 3.7.2 |
| When | 3.7.8 This library is no longer maintained, final version is 3.7.8 |
| Async | 2.6.0 ~ 2.6.3 |
| Q | 1.5.1 This library is no longer maintained, final version is 1.5.1 |
| Request | 2.18.0 ~ 2.81.0 |
| Superagent | 3.6.0 ~ 3.8.2 |